Aller au contenu

Photo

Installation KMymoney avec MacPorts


  • Veuillez vous connecter pour répondre
20 réponses à ce sujet

#1 PapiJP

PapiJP

    Membre

  • Membre
  • 11 messages
  • Gender:Male
  • Location:Notre-Dame-de-la-Merci

Posté 21 mars 2016 - 03:23

Bonjour tous le monde, je suis nouveau dans le monde de Mac. Comment ont fait pour installer KMymoney avec MacPorts ?

 

Merci de votre attention 


PapiJP


#2 Serge

Serge

    Membre

  • Root Admin
  • 3 460 messages
  • Gender:Male
  • Location:Montréal

Posté 23 mars 2016 - 10:57

Bonjour,

 

Bienvenue sur les forums. Malheureusement, j’ai l’impression que personne n’a la réponse à la question. Est-ce que ce lien peut t’aider ? Ou peut-être celui-là ?


3,3 GHz Intel Core i5 fin 2015 - 10.14,6
Computers are like houses : if you open Windows, you're gonna get bugs


#3 PapiJP

PapiJP

    Membre

  • Membre
  • 11 messages
  • Gender:Male
  • Location:Notre-Dame-de-la-Merci

Posté 25 mars 2016 - 07:35

Merci pour l'information. Une erreur apparait toujours lors du téléchargement.

 

Merci encore  


PapiJP


#4 latole

latole

    Membre

  • Membre
  • 503 messages
  • Gender:Male
  • Location:Vaudreuil-Dorion

Posté 25 mars 2016 - 01:48

Ici peut-être ? 

 

http://forum.macbido...howtopic=396000



#5 PapiJP

PapiJP

    Membre

  • Membre
  • 11 messages
  • Gender:Male
  • Location:Notre-Dame-de-la-Merci

Posté 25 mars 2016 - 07:47

Merci !


PapiJP


#6 Serge

Serge

    Membre

  • Root Admin
  • 3 460 messages
  • Gender:Male
  • Location:Montréal

Posté 26 mars 2016 - 11:19

Désolé de n’avoir pu t’aider un peu plus. Ça sort vraiment de mon champ de compétence.


3,3 GHz Intel Core i5 fin 2015 - 10.14,6
Computers are like houses : if you open Windows, you're gonna get bugs


#7 Zorgul

Zorgul

    Membre

  • Membre
  • 662 messages
  • Gender:Male
  • Location:Lasalle,Qc
  • Interests:Internet

Posté 27 mars 2016 - 02:32

C'est quoi l'erreur que tu as? Je suis plus familier avec homebrew que macport, mais bon

Mac Mini 2018 ci5 3.00ghz 32Giga (egpu Sonnet ePuck rx 560)  :: Apple TV 4 x2 :: IPhone XS Max 64Giga :: AppleWatch Series 2  :: iPad 2018 128 Giga


#8 PapiJP

PapiJP

    Membre

  • Membre
  • 11 messages
  • Gender:Male
  • Location:Notre-Dame-de-la-Merci

Posté 27 mars 2016 - 05:27

J'ai bien installer Xcode et ce message s'affiche.

 

[Users/Jean-Pierre] > install kmymoney4-devel

Warning: The Xcode Command Line Tools don't appear to be installed; most ports will likely fail to build.

Warning: Install them by running `xcode-select --install'.


PapiJP


#9 PapiJP

PapiJP

    Membre

  • Membre
  • 11 messages
  • Gender:Male
  • Location:Notre-Dame-de-la-Merci

Posté 27 mars 2016 - 05:28

A la fin c'est ca.

 

Error: Processing of port kmymoney4-devel failed


PapiJP


#10 Zorgul

Zorgul

    Membre

  • Membre
  • 662 messages
  • Gender:Male
  • Location:Lasalle,Qc
  • Interests:Internet

Posté 27 mars 2016 - 08:33

Est-ce que tu comprends l'anglais? Si c'est pas le cas c'est que l'erreur dit de rouler l'installation de Xcode pour les utilitaires à la ligne de commande!

 

le msg: Warning: Install them by running `xcode-select --install'.

 

Donc tu dois rouler: xcode-select --install

à la ligne de commande. Si cela échoue ajoute sudo avant le reste de la ligne, cela va rouler avec les privilège administrateur.


Mac Mini 2018 ci5 3.00ghz 32Giga (egpu Sonnet ePuck rx 560)  :: Apple TV 4 x2 :: IPhone XS Max 64Giga :: AppleWatch Series 2  :: iPad 2018 128 Giga


#11 PapiJP

PapiJP

    Membre

  • Membre
  • 11 messages
  • Gender:Male
  • Location:Notre-Dame-de-la-Merci

Posté 27 avril 2016 - 06:33

Désole pour le retard, j'ai une tete de cochon et je cherche a n'en plus finir. J'ai bien rouler xcode-select --install. Voici le message d'erreur.

 

version:1
:debug:main changing euid/egid - current euid: 0 - current egid: 0
:debug:main egid changed to: 501
:debug:main euid changed to: 503
:debug:main Executing org.macports.main (gmp)
:debug:main Privilege de-escalation not attempted as not running as root.
:debug:main Skipping completed org.macports.archivefetch (gmp)
:debug:main Privilege de-escalation not attempted as not running as root.
:debug:fetch fetch phase started at Wed Apr 27 19:12:46 EDT 2016
:notice:fetch --->  Fetching distfiles for gmp
:debug:fetch Executing org.macports.fetch (gmp)
:info:fetch --->  gmp-6.1.0.tar.bz2 doesn't seem to exist in /opt/local/var/macports/distfiles/gmp
:debug:fetch Spawning ping for mirrors.ibiblio.org failed
:debug:fetch Spawning ping for www.mirrorservice.org failed
:debug:fetch Spawning ping for mirror.facebook.net failed
:debug:fetch Spawning ping for ftp.funet.fi failed
:debug:fetch Spawning ping for ftp.kddlabs.co.jp failed
:debug:fetch Spawning ping for ftp.kddlabs.co.jp failed
:debug:fetch Spawning ping for ftp.dti.ad.jp failed
:debug:fetch Spawning ping for ftp.informatik.hu-berlin.de failed
:debug:fetch Spawning ping for ftp.lip6.fr failed
:debug:fetch Spawning ping for mirror.internode.on.net failed
:debug:fetch Spawning ping for ftp.unicamp.br failed
:debug:fetch Spawning ping for ftp.gnu.org failed
:debug:fetch Spawning ping for ftp.gnu.org failed
:debug:fetch Spawning ping for ftp.gnu.org failed
:debug:fetch Spawning ping for distfiles.macports.org failed
:debug:fetch Spawning ping for aarnet.au.distfiles.macports.org failed
:debug:fetch Spawning ping for cjj.kr.distfiles.macports.org failed
:debug:fetch Spawning ping for fco.it.distfiles.macports.org failed
:debug:fetch Spawning ping for her.gr.distfiles.macports.org failed
:debug:fetch Spawning ping for jnb.za.distfiles.macports.org failed
:debug:fetch Spawning ping for jog.id.distfiles.macports.org failed
:debug:fetch Spawning ping for lil.fr.distfiles.macports.org failed
:debug:fetch Spawning ping for mse.uk.distfiles.macports.org failed
:debug:fetch Spawning ping for nou.nc.distfiles.macports.org failed
:debug:fetch Spawning ping for nue.de.distfiles.macports.org failed
:debug:fetch Spawning ping for osl.no.distfiles.macports.org failed
:debug:fetch Spawning ping for sea.us.distfiles.macports.org failed
:debug:fetch Spawning ping for ykf.ca.distfiles.macports.org failed
:notice:fetch --->  Attempting to fetch gmp-6.1.0.tar.bz2 from http://mirrors.ibibl...gnu/ftp/gnu/gmp
:debug:fetch Fetching distfile failed: Could not resolve host: mirrors.ibiblio.org
:notice:fetch --->  Attempting to fetch gmp-6.1.0.tar.bz2 from http://www.mirrorser...gnu.org/gnu/gmp
:debug:fetch Fetching distfile failed: Could not resolve host: www.mirrorservice.org
:notice:fetch --->  Attempting to fetch gmp-6.1.0.tar.bz2 from http://mirror.facebook.net/gnu/gmp
:debug:fetch Fetching distfile failed: Could not resolve host: mirror.facebook.net
:notice:fetch --->  Attempting to fetch gmp-6.1.0.tar.bz2 from ftp://ftp.funet.fi/pub/gnu/prep/gmp
:debug:fetch Fetching distfile failed: Could not resolve host: ftp.funet.fi
:notice:fetch --->  Attempting to fetch gmp-6.1.0.tar.bz2 from ftp://ftp.kddlabs.co.jp/pub/gnu/gnu/gmp
:debug:fetch Fetching distfile failed: Could not resolve host: ftp.kddlabs.co.jp
:notice:fetch --->  Attempting to fetch gmp-6.1.0.tar.bz2 from ftp://ftp.kddlabs.co.jp/pub/gnu/old-gnu/gmp
:debug:fetch Fetching distfile failed: Could not resolve host: ftp.kddlabs.co.jp
:notice:fetch --->  Attempting to fetch gmp-6.1.0.tar.bz2 from ftp://ftp.dti.ad.jp/pub/GNU/gmp
:debug:fetch Fetching distfile failed: Could not resolve host: ftp.dti.ad.jp
:notice:fetch --->  Attempting to fetch gmp-6.1.0.tar.bz2 from ftp://ftp.informatik.hu-berlin.de/pub/gnu/gnu/gmp
:debug:fetch Fetching distfile failed: Could not resolve host: ftp.informatik.hu-berlin.de
:notice:fetch --->  Attempting to fetch gmp-6.1.0.tar.bz2 from ftp://ftp.lip6.fr/pub/gnu/gmp
:debug:fetch Fetching distfile failed: Could not resolve host: ftp.lip6.fr
:notice:fetch --->  Attempting to fetch gmp-6.1.0.tar.bz2 from http://mirror.intern...net/pub/gnu/gmp
:debug:fetch Fetching distfile failed: Could not resolve host: mirror.internode.on.net
:notice:fetch --->  Attempting to fetch gmp-6.1.0.tar.bz2 from ftp://ftp.unicamp.br/pub/gnu/gmp
:debug:fetch Fetching distfile failed: Could not resolve host: ftp.unicamp.br
:notice:fetch --->  Attempting to fetch gmp-6.1.0.tar.bz2 from ftp://ftp.gnu.org/gnu/gmp
:debug:fetch Fetching distfile failed: Could not resolve host: ftp.gnu.org
:notice:fetch --->  Attempting to fetch gmp-6.1.0.tar.bz2 from http://ftp.gnu.org/gnu/gmp
:debug:fetch Fetching distfile failed: Could not resolve host: ftp.gnu.org
:notice:fetch --->  Attempting to fetch gmp-6.1.0.tar.bz2 from ftp://ftp.gnu.org/old-gnu/gmp
:debug:fetch Fetching distfile failed: Could not resolve host: ftp.gnu.org
:notice:fetch --->  Attempting to fetch gmp-6.1.0.tar.bz2 from https://distfiles.macports.org/gmp
:debug:fetch Fetching distfile failed: Could not resolve host: distfiles.macports.org
:notice:fetch --->  Attempting to fetch gmp-6.1.0.tar.bz2 from http://aarnet.au.dis...mpdistfiles/gmp
:debug:fetch Fetching distfile failed: Could not resolve host: aarnet.au.distfiles.macports.org
:notice:fetch --->  Attempting to fetch gmp-6.1.0.tar.bz2 from http://cjj.kr.distfi...acports.org/gmp
:debug:fetch Fetching distfile failed: Could not resolve host: cjj.kr.distfiles.macports.org
:notice:fetch --->  Attempting to fetch gmp-6.1.0.tar.bz2 from http://fco.it.distfi...s-distfiles/gmp
:debug:fetch Fetching distfile failed: Could not resolve host: fco.it.distfiles.macports.org
:notice:fetch --->  Attempting to fetch gmp-6.1.0.tar.bz2 from http://her.gr.distfi...acports.org/gmp
:debug:fetch Fetching distfile failed: Could not resolve host: her.gr.distfiles.macports.org
:notice:fetch --->  Attempting to fetch gmp-6.1.0.tar.bz2 from http://jnb.za.distfi...g/distfiles/gmp
:debug:fetch Fetching distfile failed: Could not resolve host: jnb.za.distfiles.macports.org
:notice:fetch --->  Attempting to fetch gmp-6.1.0.tar.bz2 from http://jog.id.distfi...s/distfiles/gmp
:debug:fetch Fetching distfile failed: Could not resolve host: jog.id.distfiles.macports.org
:notice:fetch --->  Attempting to fetch gmp-6.1.0.tar.bz2 from http://lil.fr.distfi...acports.org/gmp
:debug:fetch Fetching distfile failed: Could not resolve host: lil.fr.distfiles.macports.org
:notice:fetch --->  Attempting to fetch gmp-6.1.0.tar.bz2 from http://mse.uk.distfi...acports.org/gmp
:debug:fetch Fetching distfile failed: Could not resolve host: mse.uk.distfiles.macports.org
:notice:fetch --->  Attempting to fetch gmp-6.1.0.tar.bz2 from http://nou.nc.distfi...acports.org/gmp
:debug:fetch Fetching distfile failed: Could not resolve host: nou.nc.distfiles.macports.org
:notice:fetch --->  Attempting to fetch gmp-6.1.0.tar.bz2 from http://nue.de.distfi...acports.org/gmp
:debug:fetch Fetching distfile failed: Could not resolve host: nue.de.distfiles.macports.org
:notice:fetch --->  Attempting to fetch gmp-6.1.0.tar.bz2 from http://osl.no.distfi...acports.org/gmp
:debug:fetch Fetching distfile failed: Could not resolve host: osl.no.distfiles.macports.org
:notice:fetch --->  Attempting to fetch gmp-6.1.0.tar.bz2 from http://sea.us.distfi...s/distfiles/gmp
:debug:fetch Fetching distfile failed: Could not resolve host: sea.us.distfiles.macports.org
:notice:fetch --->  Attempting to fetch gmp-6.1.0.tar.bz2 from http://ykf.ca.distfi...mpdistfiles/gmp
:debug:fetch Fetching distfile failed: Could not resolve host: ykf.ca.distfiles.macports.org
:notice:fetch --->  Attempting to fetch gmp-6.1.0.tar.bz2 from http://svn.macports....s/distfiles/gmp
:debug:fetch Fetching distfile failed: Could not resolve host: svn.macports.org
:error:fetch org.macports.fetch for port gmp returned: fetch failed
:debug:fetch Error code: NONE
:debug:fetch Backtrace: fetch failed
    while executing
"portfetch::fetchfiles"
    (procedure "portfetch::fetch_main" line 17)
    invoked from within
"portfetch::fetch_main org.macports.fetch"
    ("eval" body line 1)
    invoked from within
"eval $procedure $targetname"
:info:fetch Warning: targets not executed for gmp: org.macports.activate org.macports.fetch org.macports.checksum org.macports.extract org.macports.patch org.macports.configure org.macports.build org.macports.destroot org.macports.install
:error:fetch Failed to install gmp
:debug:fetch Registry error: libalkimia not registered as installed & active.
    invoked from within
"registry_active $subport"
    invoked from within
"$workername eval registry_active \$subport"
:notice:fetch Please see the log file for port gmp for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_devel_gmp/gmp/main.log

 

 
 
Merci !

PapiJP


#12 PapiJP

PapiJP

    Membre

  • Membre
  • 11 messages
  • Gender:Male
  • Location:Notre-Dame-de-la-Merci

Posté 27 avril 2016 - 06:35

C'est comme si impossible de se connecter 


PapiJP


#13 Zorgul

Zorgul

    Membre

  • Membre
  • 662 messages
  • Gender:Male
  • Location:Lasalle,Qc
  • Interests:Internet

Posté 27 avril 2016 - 09:12

C'est exactement cela, il ne se connecte pas.

 

notice:fetch --->  Attempting to fetch gmp-6.1.0.tar.bz2 from http://mirrors.ibibl...gnu/ftp/gnu/gmp

:debug:fetch Fetching distfile failed: Could not resolve host: mirrors.ibiblio.org
 
tu peux essayer un ping http://mirrors.ibiblio.orgà la ligne de commande. Sur mon Mac, le lien c'est ouvert et les fichiers sont là. Est-ce que tu as un utilitaire comme little snich qui fait la police pour les connections et empêche jusqu'à ce que tu autorises?

Mac Mini 2018 ci5 3.00ghz 32Giga (egpu Sonnet ePuck rx 560)  :: Apple TV 4 x2 :: IPhone XS Max 64Giga :: AppleWatch Series 2  :: iPad 2018 128 Giga


#14 PapiJP

PapiJP

    Membre

  • Membre
  • 11 messages
  • Gender:Male
  • Location:Notre-Dame-de-la-Merci

Posté 28 avril 2016 - 03:56

non je n'ai pas de police ou du moins j'ai rien installer de tel sorte. Je suis capable de faire un ping sur un autre site mais pas la: http://mirrors.ibiblio.org. Bizarre ca car je suis capable de me rendre sur mon navigateur !!!

 

iMacdeJanPierre:~ Jean-Pierre$ ping -c 6 http://fr.wikihow.com

PING j.ssl.fastly.net (23.235.46.68): 56 data bytes

64 bytes from 23.235.46.68: icmp_seq=0 ttl=56 time=24.258 ms

64 bytes from 23.235.46.68: icmp_seq=1 ttl=56 time=22.940 ms

64 bytes from 23.235.46.68: icmp_seq=2 ttl=56 time=24.879 ms

64 bytes from 23.235.46.68: icmp_seq=3 ttl=56 time=24.820 ms

64 bytes from 23.235.46.68: icmp_seq=4 ttl=56 time=24.322 ms

64 bytes from 23.235.46.68: icmp_seq=5 ttl=56 time=24.436 ms

 

--- j.ssl.fastly.net ping statistics ---

6 packets transmitted, 6 packets received, 0.0% packet loss

round-trip min/avg/max/stddev = 22.940/24.276/24.879/0.642 ms

iMacdeJanPierre:~ Jean-Pierre$ ping -c 6 http://mirrors.ibiblio.org/

ping: cannot resolve http://mirrors.ibiblio.org/:Unknown host

iMacdeJanPierre:~ Jean-Pierre$


PapiJP


#15 PapiJP

PapiJP

    Membre

  • Membre
  • 11 messages
  • Gender:Male
  • Location:Notre-Dame-de-la-Merci

Posté 28 avril 2016 - 04:16

tu va comprendre que je suis nouveau sur MAC. je ne sais plus quoi écrire.

 

iMacdeJanPierre:~ Jean-Pierre$ install kmymoney4-devel

usage: install [-bCcpSsv] [-B suffix] [-f flags] [-g group] [-m mode]

               [-o owner] file1 file2

       install [-bCcpSsv] [-B suffix] [-f flags] [-g group] [-m mode]

               [-o owner] file1 ... fileN directory

       install -d [-v] [-g group] [-m mode] [-o owner] directory ...

iMacdeJanPierre:~ Jean-Pierre$

 

As tu un site pour que je puisse me familiariser avec le language 

 

Merci encore !


PapiJP


#16 Zorgul

Zorgul

    Membre

  • Membre
  • 662 messages
  • Gender:Male
  • Location:Lasalle,Qc
  • Interests:Internet

Posté 28 avril 2016 - 07:09

Il semble que ton DNS ne sais pas résoudre mirrors.ibiblio.org

 

moi:

yannmac:etc yannbourdeau$ ping mirrors.ibiblio.org

PING mirrors.ibiblio.org (152.19.134.44): 56 data bytes

64 bytes from 152.19.134.44: icmp_seq=0 ttl=55 time=46.169 ms

64 bytes from 152.19.134.44: icmp_seq=1 ttl=55 time=44.195 ms

64 bytes from 152.19.134.44: icmp_seq=2 ttl=55 time=44.269 ms

64 bytes from 152.19.134.44: icmp_seq=3 ttl=55 time=44.718 ms


Mac Mini 2018 ci5 3.00ghz 32Giga (egpu Sonnet ePuck rx 560)  :: Apple TV 4 x2 :: IPhone XS Max 64Giga :: AppleWatch Series 2  :: iPad 2018 128 Giga


#17 Zorgul

Zorgul

    Membre

  • Membre
  • 662 messages
  • Gender:Male
  • Location:Lasalle,Qc
  • Interests:Internet

Posté 28 avril 2016 - 07:15

Quel fournisseur internet as-tu?

 

Tu peux faire la bidouille suivante:

à la ligne de commande:

sudo vi /etc/hosts

 - Une fois le fichier ouvert: descends avec les curseurs à la dernière ligne.

- Fait shift-A. tu vas en mode insertion à la fin de la ligne.

-Appuie sur enter pour commencer sur une nouvelle ligne

entre: 152.19.134.44 mirrors.ibiblio.org

ensuite: appuie sur enter.

 

appuie sur escape

ensuite appuie sur : 

ensuite entre wq

appuie sur enter.

 

Tu peux trouver des guides en ligne sur vi (éditeur de textes).

 

Le fichier /etc/hosts permet de dire à l'ordinateur comment résoudre un hostname à un IP. Ce que ton DNS ne semble pas être en mesure de résoudre.


Mac Mini 2018 ci5 3.00ghz 32Giga (egpu Sonnet ePuck rx 560)  :: Apple TV 4 x2 :: IPhone XS Max 64Giga :: AppleWatch Series 2  :: iPad 2018 128 Giga


#18 PapiJP

PapiJP

    Membre

  • Membre
  • 11 messages
  • Gender:Male
  • Location:Notre-Dame-de-la-Merci

Posté 28 avril 2016 - 07:55

Comme tu peu voir ca fonctionne avec une autre application !!!

 

iMacdeJanPierre:~ Jean-Pierre$ sudo port install apg

Password:

--->  Computing dependencies for apg

--->  Fetching archive for apg

--->  Attempting to fetch apg-2.2.3_2.darwin_15.x86_64.tbz2 from https://packages.macports.org/apg

--->  Attempting to fetch apg-2.2.3_2.darwin_15.x86_64.tbz2 from http://lil.fr.packag...acports.org/apg

--->  Attempting to fetch apg-2.2.3_2.darwin_15.x86_64.tbz2 from http://mse.uk.packag...acports.org/apg

--->  Fetching distfiles for apg

--->  Verifying checksums for apg

--->  Extracting apg

--->  Applying patches to apg

--->  Configuring apg

--->  Building apg

--->  Staging apg into destroot

--->  Installing apg @2.2.3_2

--->  Activating apg @2.2.3_2

--->  Cleaning apg

--->  Updating database of binaries

--->  Scanning binaries for linking errors

--->  No broken files found.

 

Merci pour le lien 


PapiJP


#19 Zorgul

Zorgul

    Membre

  • Membre
  • 662 messages
  • Gender:Male
  • Location:Lasalle,Qc
  • Interests:Internet

Posté 28 avril 2016 - 09:28

oui parce c'est pas sur le même site mirrors.ibiblio.org. Si tu regarde les from de la commande qui fonctionne.


Mac Mini 2018 ci5 3.00ghz 32Giga (egpu Sonnet ePuck rx 560)  :: Apple TV 4 x2 :: IPhone XS Max 64Giga :: AppleWatch Series 2  :: iPad 2018 128 Giga


#20 PapiJP

PapiJP

    Membre

  • Membre
  • 11 messages
  • Gender:Male
  • Location:Notre-Dame-de-la-Merci

Posté 07 juin 2016 - 07:27

Merci pour ton aide et ta patiente, j'avais lancer la serviette un bout de temps. Ce matin je me suis remis dedans et j'ai essayer de télécharger une autre application avec succès. Donc j'ai refait une tentative pour KMymoney et cela as fonctionner a merveille. Bizarre mais content.

 

Merci encore de ton attention  :yahoo:


PapiJP


#21 Zorgul

Zorgul

    Membre

  • Membre
  • 662 messages
  • Gender:Male
  • Location:Lasalle,Qc
  • Interests:Internet

Posté 07 juin 2016 - 11:57

Ton DNS (Domain Name Server) qui n'est pas sur ton PC mais, chez ton ISP, doit être en mesure de résoudre mirrors.ibiblio.org maintenant. C'est pour cela que cela fonctionne.

 

Fait plaisir, j'aime cela me promener sur ce forum et essayer de résoudre le problème du monde qui poste. Cela m'occupe!


Mac Mini 2018 ci5 3.00ghz 32Giga (egpu Sonnet ePuck rx 560)  :: Apple TV 4 x2 :: IPhone XS Max 64Giga :: AppleWatch Series 2  :: iPad 2018 128 Giga





0 utilisateur(s) li(sen)t ce sujet

0 membre(s), 0 invité(s), 0 utilisateur(s) anonyme(s)